Bad performance on Huawei Mate 10 Pro

Voice your bugs/glitches encounters or workarounds you find. While this forum is unofficial, we welcome Disney developers to stop by to help.
andrew8147
Storm Trooper
Posts: 3

Bad performance on Huawei Mate 10 Pro

Post#1 » Mon Jan 01, 2018 5:43 am

Hi all,

I have purchased brand new Huawei Mate 10 Pro. I expected that game runs smooth on my new device but I was disappointed when I launched a game. The game loads too long and it is laggy. Also textures looks very bad. Game looks better even on my iPhone SE which is much older device.
I would like to ask you if Star Wars Commander is also optimized for Kirin CPU which is built in Huawei devices. I dont believe that has lack of power to run this game smoothly. (8 core CPU + 6GB RAM).

Thanks for reply.


Plagueis
Grand Admiral
Posts: 1226

Re: Bad performance on Huawei Mate 10 Pro

Post#2 » Mon Jan 01, 2018 8:47 am

Cellular or Wi-Fi connection? A bad connection can cause the described issues.


andrew8147
Storm Trooper
Posts: 3

Re: Bad performance on Huawei Mate 10 Pro

Post#3 » Mon Jan 01, 2018 11:09 am

it is not caused by connection. I am connected to same wifi with my iPhone SE and also with my new Huawei device.


User avatar
DeathStriker
Moderator
Posts: 3640

Re: Bad performance on Huawei Mate 10 Pro

Post#4 » Mon Jan 01, 2018 11:51 am

andrew8147 wrote:it is not caused by connection. I am connected to same wifi with my iPhone SE and also with my new Huawei device.

andrew8147 - The Android Phone - HUAWEI Mate 10 Pro - should run SWC ok...

If you are having Game Issues I suggest you first try to turn off Game Device and restart and then first thing try game to see if other "apps" might be interfering...

You can also try to contact Disney Mobile Support but I am not sure what they can do for "hardware" related problems.

I don't think your Processor or OS is the issue.
 
Image
Death_Striker is looking for ALL Rebel Commanders
Sons_of_Death is looking for Level 8+ Rebel Commanders
If YOU Want to War - Apply Now!


cerestan
Officer
Posts: 8

Re: Bad performance on Huawei Mate 10 Pro

Post#5 » Tue Jan 02, 2018 2:46 am

I'm running on an Honor 8 which has a lesser Kirin cpu than yours and I've not experienced the issues you're having. I think your chip is meant to have much improved 3D performance.

Try running a few other games and see what their performance is like. You could also run a benchmark app to see if you're getting the expected results.


DarkRebel
Admiral
Posts: 648

Re: Bad performance on Huawei Mate 10 Pro

Post#6 » Tue Jan 02, 2018 5:34 am

Plagueis wrote:Cellular or Wi-Fi connection? A bad connection can cause the described issues.

Likely this.
The “Load too long” is likely not related to graphic and more with data speed.
Try running a free speedtest program to see how the speed is like for your wifi network.


andrew8147
Storm Trooper
Posts: 3

Re: Bad performance on Huawei Mate 10 Pro

Post#7 » Wed Jan 03, 2018 12:35 am

Thanks for replies guys, but problem is really not related to my connection. I use 80Mbps wifi connection and LTE mobile network. Same connection is used either by iPhone SE and Mate 10. Game still runs smoothly on iPhone than on Mate 10. Yesterday I did AnTuTu benchmark and I got more than 176000 points, that should be sufficient to run SWC smoothly.


Return to “Bugs and Glitches (iOS/Android)”

Who is online

Users browsing this forum: Google Adsense [Bot], SuCCeSSvS and 5 guests